Search My Techie Guy

Ad from yllix

Wednesday, December 21, 2016

LG Fuzzy Logic 10Kg Top Loader Washing Machine - water enters and drains out - Doesn't start the washing cycle

Summary:

Am working with an LG Fuzzy Logic 10KG Top Loader washing machine (TurboDrum), it's new and i have been asked to test it. 

LG TurboDrum Washing Machine

The plumbing and power has already been installed by another person which was a bit unfortunate as you will later realize in this article, because my role was to test as a user and not end up troubleshooting the machine and plumbing. 


The cold water inlet plumbing was done perfectly, it's falling from a good height and the water supply pressure is good.

The challenge is water enters the machine fine but never fills, it instantly drains out (actually siphons out without being pushed by the pump).



Problem or Goal:

with the water siphoning out freely, the wash cycle doesn't start, the machine only agitates for about 8 seconds and gets stuck at some point after only 2 minutes.

Cause:

After hours of frustration and trying everything including a master reset, the problem cause was as simple as "bad plumbing".
The drain hose that drains the water out of the machine was installed lower than the drum level. so the drum will never fill.

Solution:

Follow the recommended operating manual, make sure the drain hose is hung up to a level higher than the drum filling level before operating the washing machine.



Problem Solved?

Yes, the drain hose was moved from down to a level up higher than the drum filling level, the machine was powered off and on again and it was able to fill and start the wash cycle. i have just finished my first round of laundry. good luck.

Credits: 

This was a useful link during this troubleshooting, thanks.







Friday, December 16, 2016

Diesel filter warning on my Land cruiser VX limited - HZ Engine

Summary: 

Diesel filter warning on my land cruiser VX limited.


Diesel Filter Warning
Problem or Goal:

My VX land cruiser is displaying a warning on the dash board and when i checked on internet, it stands for "diesel filter" warning.

Cause:

My mechanic removed the diesel filter and the fuel inside the filter seems to be contaminated with water. he poured the fuel in a glass container and you could observe the suspension mixture of fuel on top and water at the bottom.

Solution:

We suspected that the fuel tank could be the problem, i didn't have enough time to remove the entire fuel tank, clean it and dry it. so my mechanic advised that we just empty the tank, replace the diesel filter and fuel with new fuel. we did that and the alarm cleared, however on my way from Kampala to Mbarara (almost 3 quarters of a 260KM journey ) the alarm reappeared.

The next move when i go back to Kampala is to go with the first suggestion of dropping the entire fuel tank and cleaning it dry, and replacing the filter again.

My mechanic mentioned to me that this is a serious issue and i should not just ignore this alarm as such fuel can kill the diesel fuel injector nozzles. so as a temporary fix, am going to again replace the filter on my way back to kampala to project my nozzles since the nozzles cost a lot more than a filter of 25,000 UGX. Nozzles can go for 1,500,000 UGX am warned!

Problem Solved?

Problem not yet solved, will update this post once solved.

Thursday, December 1, 2016

ChapChap African - Uganda Version Hits the market with both customer and business associate options

This is one mobile app that is just about to revolutionize the way Ugandans access and pay for services in Uganda.

ChapChap Africa - Uganda version is launched and available on Google Play with the option of signing up as the business associate or normal customer. 
ChapChap is payment platform built around social media and internet marketing with a focus on offering the end-user convenience and also reward them through royalty cashbacks.

User and Business Associates will also earn commissions from referring fellow users and agents.
As your techie guy, am already taking this APP for a spin and i can say; "i endorse ChapChap"
and below is the message am sending to my people. don't be left behind, sign up today, the benefits are endless and if you are considering a secondary cash channel and you are in Uganda, this is it. you can thank me later.

ChapChap Payment Platform

Am inviting you to join ChapChap, the most convenient way to pay for; Airtime, Internet, TV, Yaka, Water and much more. ChapChap is not only convenient but also rewarding. Earn royalty cashbacks when you purchase using ChapChap. There is also a business opportunity if you choose to sign up as a Business Associate and earn commissions from referrals on top of the cashbacks from transactions. Simply go to Google Play Store and search for “ChapChap”, download and install the App. Use referral number: 0752605595 to complete the signup. If you choose to sign up as a Business Associate, contact me so I can guide you through the process, but if you choose to sign up as a customer, it’s free and you can fund you ChapChap wallet direct from your mobile money or Airtel money account. Simply go to “Buy Stock” on your ChapChap APP and follow the prompts. It’s smooth and easy. Cheers


Ask me about “ChapChap” 

Saturday, November 12, 2016

Giving a normal linux user root(sudo) privileges

Summary: 

Giving a linux user root(sudo) privileges 

Problem or Goal:

Allowing a normal linux user sudo privileges

Cause: 

In most cases, you may want to grant some user on the linux system, root privileges.

Solution: 

1. Edit the /etc/sudoers file and add the user you wish to grant sudo right to this sudoers file. Take forexample the user "exampleuser"

# visudo

# more /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
#
# See the man page for details on how to write a sudoers file.
#
Defaults        env_reset
Defaults        mail_badpass
Defaults        secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/
sbin:/bin"

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root    ALL=(ALL:ALL) ALL
exampleuser ALL=(ALL:ALL) ALL

2. Save the changes
3. Now run the command "sudo su" when logged in as the exampleuser:

$ sudo su

4. Enter the exampleuser password, you will see the prompt changing to the one similar to root.

Problem Solved?

yes

Monday, October 24, 2016

Editing the Windows "hosts" file to override the network DNS resolution

Summary: 

Editing the Windows "hosts" file to override the network DNS resolution 

Problem or Goal:

How to edit the "hosts" file on windows machine, this overrides the network DNS answer.

Cause:

In most cases, especially while testing new website installs on hostgator cpanel for domain names that are already in production, i find myself in a situation where i have to edit the "hosts" file on my PC to point to a hostgator server. when am done testing, i delete the entry i had made in the hosts file and point the domain to the hostgator DNS servers.

This helps me to test the site locally on my laptop without interfering with the live website.

Solution: 

File Location:  C:\Windows\System32\drivers\etc

################################################
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1       localhost
# ::1             localhost

127.0.0.1       localhost

192.185.32.240 www.clientdomain.com

###############################################

Problem Solved?

yes

Gator4043 Hostgator Manual email settings

Summary: 

Gator4043 Hostgator Manual email settings

Problem or Goal:

Configuring your email client for example outlook for hostgator email services 

Cause:

Incase your email client doesn't support automatic configuration script. 

Solution:

Manual Settings


Secure SSL/TLS Settings
(Recommended)
Username:name@yourdomain.com
Password:Use the email account’s password.
Incoming Server:gator4043.hostgator.com
  • IMAP Port: 993
  • POP3 Port: 995
Outgoing Server:gator4043.hostgator.com
  • SMTP Port: 465
Authentication is required for IMAP, POP3, and SMTP.
 

Non-SSL Settings
Username:name@yourdomain.com
Password:Use the email account’s password.
Incoming Server:mail.yourdomain.com
  • IMAP Port: 143
  • POP3 Port: 110
Outgoing Server:mail.yourdomain.com
  • SMTP Port: 25
Authentication is required for IMAP, POP3, and SMTP.
Problem Solved?

Yes

Wednesday, October 12, 2016

Configuring TACACs+ for Juniper Routers and Switches with virtual routing instances

Summary: 

Today i found myself in a situation where i have to add some juniper switches (EX4200s and EX4500s) to our TACACs+ server, for the switches where the remote access IP was configured on the management interface (me0) or any other interface but accessible from the global routing table (inet.0) i didn't face any issues.

However, for switches were the operation and maintenance IP was configured within a routing instance, i had issues because there is no routing-instance specific configuration for TACACs+

TACACs+ server has to be reachable from the global routing table.

Problem or Goal:

Configuring TACACs on a switch with routing instances and VRFs

Cause:

TACACs+ server has to be reachable from the global routing table.

Solution:

Instead of using vlan routed interfaces or the normal interfaces bound to a routing instance, use the management interface (me0).
Juniper has an interface dedicated for management that uses the control plane and is useful for out-of-band management.

Example:

If you have virtual chassis enabled:

set interfaces vme unit 0 family inet address 10.172.2.2/24

if you are working on a single switch without virtual chassis:

set interfaces me0 unit 0 family inet address 10.172.2.2/24

You will need to connect the MGT interfaces to your LAN network.

You also need to add this part of configuration on the switch according to your TACACs server details:

set system login user remote full-name "Tacacs+ System User"
set system login user remote uid xxxx
set system login user remote class super-user

set system authentication-order tacplus
set system authentication-order password

set system tacplus-server 10.0.X.X port 49
set system tacplus-server 10.0.X.X secret tacacs_secret_key
set system tacplus-server 10.0.X.X single-connection
set system tacplus-server 10.0.X.X source-address 10.172.2.2


set system accounting events [ change-log interactive-commands login ] destination tacplus server 10.0.X.X

Don't forget to create a failover local login incase TACACs+ is offline:

set system login user admin uid xxxx
set system login user admin class super-user

set system login user admin authentication plain-text-password

Problem Solved?

Yes

Tuesday, October 11, 2016

What's the best link to watch movies/series/tv shows online anywhere in the world?

Note to self:

This link is so far my best guess: 

TUBEPLUS

1. Use the search bar to search for the show or movie you are interested in.
2. Click on the show.

tubeplus.ag

3. Follow through and click on the season you want to watch.
4. Select the content provider or host, you can base your decision on the reviews, but i recommend
    host: thevideo.me

host: thevideo.me


Monday, October 10, 2016

How to reset IPsec tunnel - Juniper SRX

Summary: 

Resetting IPsec tunnel in Juniper

Problem or Goal:

Resetting IPsec tunnel in most cases allows the end point devices to renegotiate the configured parameters to establish a fresh security association, this is a useful step in troubleshooting problematic IPsec issues.


Cause:

mismatch or change in tunnel parameters, or if the tunnel has hang or is unstable. 

Solution: 

clear security ike security-associations    index XXX
clear security ipsec security-associations indexXXX

Problem Solved?

Tuesday, October 4, 2016

Common DNS query return messages and response codes and their meaning

Summary:

Common DNS query return messages and response codes and their meaning

Problem or Goal:

when trying to resolve a domain/host-name 

Cause:

DNS error

Solution:

DNS Return Message
DNS Response Code 
Function
 NOERROR
RCODE:0
 DNS Query completed successfully
 FORMERR
RCODE:1
 DNS Query Format Error
 SERVFAIL
RCODE:2
 Server failed to complete the DNS request
 NXDOMAIN
RCODE:3
 Domain name does not exist.  
 NOTIMP
RCODE:4
 Function not implemented
 REFUSED
RCODE:5
 The server refused to answer for the query
 YXDOMAIN
RCODE:6
 Name that should not exist, does exist
 XRRSET
RCODE:7
 RRset that should not exist, does exist
 NOTAUTH
RCODE:8
 Server not authoritative for the zone
 NOTZONE
RCODE:9
 Name not in zone

Problem Solved?

Tuesday, August 23, 2016

Please allow storage permissions in order to play FIFA 16 UT - Redmi Note 3 MIUI Version

Summary: 

After successfully downloading and installing FIFA 16 UT on my Redmi Note 3, i get this error:
"Please allow storage permissions in order to play FIFA 16 UT."

Problem or Goal:

Error while trying to load a new game/app installed on my android phone.


Please allow storage permissions in order to play FIFA 16 UT.

Cause:

Looks like a file permissions issue

Solution: 

Follow the pictorial "how to?" below to allow the FIFA app access to your device's storage before you it can successfully launch. 

1. There is a "Security" App on the Redmi Note 3, open it
Open the security app on your phone
2. Select Permissions
Go to the permissions menu

3. Open the permissions options
open permissions options
4. Go to storage
go to storage
5. Allow FIFA app to access the storage by enabling the button
enable FIFA 
Problem Solved?

Yes, try to launch the game/app again
FIFA now launches fine

Friday, August 12, 2016

Installing Tacacs plus to manage juniper routers, switches and firewalls

Summary:

Today am tasked with installing tacacs+ to manage authentication to all the IP nodes, most of the nodes here are juniper. sorry i won't be very organized in writing this article, i will pretty much paste every challenge and solution as i work, in fact this will be my new style of work instead of waiting to first finish the work and then putting in more time to write a clean article. let's face it, i suck at writing and am lazy just like all other engineers :-), so sorry if this article is a mess.

Problem or Goal:

To install TACACS+ to manage authentication to juniper nodes (routers, switches, firewalls)

Cause:

Consider this a good house keeping cause, you need centralized management of logins, logging, easy to manage users and an added layer of security.

Solution:

Working on setting up the server side

1. Platform

# cat /etc/*release
openSUSE 13.2 (x86_64)
VERSION = 13.2

2. Download site for TACACS+ rpm
3. ftp/sftp the above file to your server; you can use FileZilla or WinSCP
4. Install using Zypper (but oops, looks like i have some missing dependencies!!! welcome to the opensource world :-) )

# zypper --non-interactive install tac_plus-4.0.4.26-1.52.x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libtacacs.so.1()(64bit) needed by tac_plus-4.0.4.26-1.52.x86_64
 Solution 1: do not install tac_plus-4.0.4.26-1.52.x86_64
 Solution 2: break tac_plus-4.0.4.26-1.52.x86_64 by ignoring some of its dependencies

5. Download site for libtacacs

libtacacs1 rpm build for : OpenSuSE. For other distributions click libtacacs1.

Name : libtacacs1
Version : 4.0.4.26Vendor : obs://build_opensuse_org/home:anubisg1
Release : 1.52Date : 2013-08-24 07:40:02
Group : Development/Languages/C and C++Source RPM : tac_plus-4.0.4.26-1.52.src.rpm
Size : 0.35 MB
Packager : (none)
Summary : Tacacs+ library
Description :
This package contains TACACS+ library

RPM found in directory: /mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/anubisg1:/networking/openSUSE_Factory/x86_64

Download
ftp.pbone.netlibtacacs1-4.0.4.26-1.52.x86_64.rpm
     

6. Similarly download and ftp this package to your server
7. Install the libtacacs rpm as below:

# zypper --non-interactive install libtacacs1-4.0.4.26-1.52.x86_64.rpm 
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  libtacacs1 

1 new package to install.
Overall download size: 24.1 KiB. Already cached: 0 B  After the operation, additional 354.6 KiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package libtacacs1-4.0.4.26-1.52.x86_64                                                                                                                          (1/1),  24.1 KiB (354.6 KiB unpacked)
Checking for file conflicts: ..............................................................................................................................................................................[done]
(1/1) Installing: libtacacs1-4.0.4.26-1.52 ................................................................................................................................................................[done]
Additional rpm output:
warning: /var/cache/zypp/packages/_tmpRPMcache_/libtacacs1-4.0.4.26-1.52.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e558cb38: NOKEY

8. Now re-attempt to the tac_plus installation, this time it should be successful after adding the libtacacs dependency

# zypper --non-interactive install tac_plus-4.0.4.26-1.52.x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  tac_plus 

1 new package to install.
Overall download size: 95.1 KiB. Already cached: 0 B  After the operation, additional 229.0 KiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package tac_plus-4.0.4.26-1.52.x86_64                                                                                                                            (1/1),  95.1 KiB (229.0 KiB unpacked)
Checking for file conflicts: ..............................................................................................................................................................................[done]
(1/1) Installing: tac_plus-4.0.4.26-1.52 ..................................................................................................................................................................[done]
Additional rpm output:
warning: /var/cache/zypp/packages/_tmpRPMcache_/tac_plus-4.0.4.26-1.52.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e558cb38: NOKEY

9. Test your installation, looks good :-) 

# tac_plus -v
tac_plus version F4.0.4.26
ACLS
FIONBIO
LIBWRAP
LINUX
LITTLE_ENDIAN
LOG_DAEMON
PAM
NO_PWAGE
REAPCHILD
RETSIGTYPE RETSIGTYPE
SHADOW_PASSWORDS
SIGTSTP
SIGTTIN
SIGTTOU
SO_REUSEADDR
STRERROR
TAC_PLUS_PORT
UENABLE
__STDC__

10. Tacacs config file is located at: 

/etc/tac_plus.conf 

11. Tacacs manual is located at: 

# man tac_plus

12. The tacacs plus daemon is found at:
# /etc/init.d/tac_plus
Usage: tacacs {start|stop|status|restart|reload}

13. Starting tacacs (oops looks like we have an error! )

SMPP:/etc/init.d # ./tac_plus start
./tac_plus: line 16: /etc/rc.d/init.d/functions: No such file or directory
./tac_plus: line 19: .: /etc/sysconfig/network: is a directory
./tac_plus: line 22: [: =: unary operator expected
Starting tacacs+: ./tac_plus: line 35: daemon: command not found

14. Edit the tacacs plus init file to comment out the above lines and also delete the "daemon" command
# vi /etc/init.d/tac_plus

# Source function library.
#. /etc/rc.d/init.d/functions

# Source networking configuration.
#. /etc/sysconfig/network

start)
        # Start daemons.
        echo -n "Starting tacacs+: "
        /usr/bin/tac_plus -C $CONFIG ${LOGFILE:+-l $LOGFILE}  ${WHOLOG:+-w $WHOLOG} ${DEBUG_LEVEL:+-d $DEBUG_LEVEL}
        RETVAL=$?
        echo
        [ $RETVAL == 0 ] && touch /var/lock/subsys/tac_plus
        ;;

15. Attempt to start tacacs again:
SMPP:/etc/init.d # /etc/init.d/tac_plus start
Starting tacacs+: 

16. check to make sure it's running in the processes

SMPP:/etc/init.d # ps -ef | grep tac
root     20176     1  0 20:26 pts/0    00:00:00 /usr/bin/tac_plus -C /etc/tac_plus.conf







Problem Solved?

Monday, August 1, 2016

QoS Parameters to consider when setting the SLAs for VOIP Networks

Am currently working on a draft SLA (Service Level Agreement) with a VOIP carrier, here is a useful link i came across to guide me in setting the maximum allowed values, for both the transmission links and the end to end voice calls.

Things to consider are:

  • Latency: Delay for packet delivery
  • Jitter: Variations in delay of packet delivery
  • Packet loss: Too much traffic in the network causes the network to drop packets
  • Burstiness of Loss and Jitter: Loss and Discards (due to jitter) tend to occur in bursts

Friday, June 17, 2016

How to configure port mirroring on juniper MX series routers?

Summary: 

How to configure port mirroring on juniper MX series routers?

Problem or Goal:

You are in a situation where you want to capture and analyse live traffic in/out of a juniper MX series router interface. The most common network analyzer tool is wireshark.

Cause:

There are so many scenarios why you might want to capture and analyze network traffic at protocol level, in many cases you would be troubleshooting an application or network problem.

Solution:

In this example, a laptop with a network analyzer tool (Wireshark) is connected to port ge-1/1/2 of the router.
The traffic of interest is in/out of interfaces ge-1/1/0 and ge-1/1/1, i.e. from the clients laptops towards the webserver, two-way. 



Port Mirroring on Juniper MX series routers
1. Configure the interface where you are going to connect the wireshark laptop

set interface ge-1/1/2 description to_wireshark_laptop 
set interface ge-1/1/2 unit 0 family inet address 192.168.0.1/30
set interfaces ge-1/1/2 unit 0 family inet address 192.168.0.1/30 arp 192.168.0.2 mac A0:1D:48:B3:A1:26

2. Create the filter for example this filter is called "wireshark_capture"

set firewall filter wireshark_capture term 1 from source-address 0.0.0.0/0
set firewall filter wireshark_capture  term 1 from destination-address 0.0.0.0/0
set firewall filter wireshark_capture term 1 then port-mirror
set firewall filter wireshark_capture term 1 then count output-pm
set firewall filter wireshark_capture term 1 then accept

set firewall filter wireshark_capture term allow-all-else then accept

3. Apply the filter to the interfaces carrying the traffic of interest

set interfaces ge-1/1/0  unit 0 family inet filter output wireshark_capture 
set interfaces ge-1/1/0  unit 0 family inet filter input wireshark_capture 
set interfaces ge-1/1/1  unit 0 family inet filter output wireshark_capture 
set interfaces ge-1/1/1  unit 0 family inet filter input wireshark_capture 

4. Configure the port mirror

set forwarding-options port-mirroring input rate 1
set forwarding-options port-mirroring input run-length 1
set forwarding-options port-mirroring family inet output interface ge-1/1/2.0 next-hop 192.168.0.2
set forwarding-options port-mirroring family inet output no-filter-check

5. Commit the configuration

#commit check
#commit