References:
1. Create VLAN interfaces and add physical ports
2. Configure the trunk port to carry multiple vlans
3. Create bridges to forward traffic from the access ports to the trunk port
“It has become appallingly obvious that our technology has exceeded our humanity.” Albert Einstein
Thursday, December 17, 2015
Friday, November 13, 2015
Connected a firewall (SRX240) but i can't ping the Point to Point Interfaces
Problem:
Just completed connecting a firewall (SRX 240) to a switch.
The link is supposed to be a trunk carrying multiple VLANs, however, i couldn't ping the Point-to-Point IPs from the switch or the firewall yet the interfaces are UP.
Example Config:
On the Firewall:
set interfaces ge-0/0/13 description my_test_link
set interfaces ge-0/0/13 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/13 unit 0 family ethernet-switching vlan members TEST
set interfaces vlan unit 590 description my_test_vlan
set interfaces vlan unit 590 family inet address 10.0.90.5/30
set vlans TEST vlan-id 590
set vlans TEST l3-interface vlan.590
On the switch:
set interfaces ge-0/0/16 description my_test_link
set interfaces ge-0/0/16 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members 590
set interfaces vlan unit 590 description my_test_vlan
set interfaces vlan unit 590 family inet address 10.0.90.6/30
set vlans TEST vlan-id 590
set vlans TEST l3-interface vlan.590
Normally, this would be enough to bring UP the point-to-point if this were a switch to switch connection. But because the default firewall behavoiur is to block all traffic, trying to ping the firewall interfaces from the switch or vice versa will fail.
solution:
Add this config
set security zones security-zone trust interfaces vlan.590
set security zones security-zone trust interfaces vlan.590 host-inbound-traffic system-services all
set security zones security-zone trust interfaces vlan.590 host-inbound-traffic protocols all
what this additional config does is to put the interface in a security zone and permit inbound traffic to that interface.
Just completed connecting a firewall (SRX 240) to a switch.
The link is supposed to be a trunk carrying multiple VLANs, however, i couldn't ping the Point-to-Point IPs from the switch or the firewall yet the interfaces are UP.
Example Config:
On the Firewall:
set interfaces ge-0/0/13 description my_test_link
set interfaces ge-0/0/13 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/13 unit 0 family ethernet-switching vlan members TEST
set interfaces vlan unit 590 description my_test_vlan
set interfaces vlan unit 590 family inet address 10.0.90.5/30
set vlans TEST vlan-id 590
set vlans TEST l3-interface vlan.590
On the switch:
set interfaces ge-0/0/16 description my_test_link
set interfaces ge-0/0/16 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members 590
set interfaces vlan unit 590 description my_test_vlan
set interfaces vlan unit 590 family inet address 10.0.90.6/30
set vlans TEST vlan-id 590
set vlans TEST l3-interface vlan.590
Normally, this would be enough to bring UP the point-to-point if this were a switch to switch connection. But because the default firewall behavoiur is to block all traffic, trying to ping the firewall interfaces from the switch or vice versa will fail.
solution:
Add this config
set security zones security-zone trust interfaces vlan.590
set security zones security-zone trust interfaces vlan.590 host-inbound-traffic system-services all
set security zones security-zone trust interfaces vlan.590 host-inbound-traffic protocols all
what this additional config does is to put the interface in a security zone and permit inbound traffic to that interface.
Friday, November 6, 2015
Saturday, October 24, 2015
How to Align "Center" wordpress theme twenty fourteen
Wednesday, October 14, 2015
Error 500 - Internal server error hostgator after extracting a joomla quickstart
Credits: Joomla Forum (click here to follow the original thread)
Error 500 - internal server error hostgator after extracting a joomla quickstart |
Monday, September 21, 2015
Online tool to remove white spaces and tabs from a text file
Note to self: I use this tool a lot in my daily work. especially to prepare configuration files:
Online Tool to remove white spaces from a text file
Online Tool to remove white spaces from a text file
Thursday, September 17, 2015
Here are some tools you can use to manage ubiquiti devices
Another note to self:
Below is a link to the tools i need to try out with managing UBIQUITI devices.
airControl - AC2 Beta14
Below is a link to the tools i need to try out with managing UBIQUITI devices.
airControl - AC2 Beta14
Make use of radio mobile online - draw coverage maps for your wireless network
Another note to self:
Radio Mobile Online - Free online tool to draw coverage maps for wireless radio networks.
Am going to use this tool to draw a coverage map for my UBIQUITI (airMAX) p2mp wireless network.
Radio Mobile Online - Free online tool to draw coverage maps for wireless radio networks.
Am going to use this tool to draw a coverage map for my UBIQUITI (airMAX) p2mp wireless network.
Tuesday, September 15, 2015
Vodafone Uganda 2G-3G-4G Network Settings for Voice and Data
Vodafone Uganda Network settings for handsets and data devices:
For 2G/3G handsets:
·
Initiate a manual search for
the network provider and select either ‘VODAFONE 3G/4G’ or ‘64118’
·
Set your SMS service Centre number
to +256723000300
·
Ensure your Vodafone Access Point
Name (APN) is set to ‘internet’
For 4G
handsets:
·
Initiate a manual search for
the network provider and select either ‘Vodafone UG’ or ‘64106’
·
Set your SMS service Centre number
to +256723000300
·
Ensure your Vodafone Access Point
Name (APN) is set to ‘internet’
Note: It
may take up to 1½ minutes for the network search to be done. Once you
have selected the network, it may be displayed
in
different ways e.g. the iPhone 6 display shows as “v”.
For data
devices:
· Enter the web address for to enter the online management interface:
§ Username – admin, Password - admin
§ Username – admin, Password - admin
§ Username – admin, Password – admin
§ Username – Admin, Password – Admin
· Select Settings, then choose Network settings or Internet
Connection
· Go to the Network Mode or Network Preference and
select Auto or LTE/3G
· Ensure your Vodafone Access Point Name (APN) is set to ‘internet’
Monday, September 7, 2015
Bandwidth limiting a sub-interface on a cisco ios router
The configuration below will limit the uplink and downlink bandwidth of the specified interface on a cisco router:
Step 1: Create a policy map e.g "allowed_bw_3M" to limit uplink and downlink to 3Mbps
Router#configure t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#policy-map allowed_bw_3M
Router(config-pmap)#class class-default
Router(config-pmap-c)#police cir 3072000
Note: 3 x 1024 x 1000 = 3072000 (convert to bit rate or biTs per second)
Router(config-pmap-c-police)#conform-action transmit
Router(config-pmap-c-police)#exceed-action drop
Router(config-pmap-c-police)#end
#
Step 2: Apply the policy to the interface
#
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet0/0.512
Router(config-subif)#service-policy input allowed_bw_3M
Router(config-subif)#service-policy output allowed_bw_3M
Router(config-subif)#do wr
Building configuration...
[OK]
Router(config-subif)#end
#
You can use speed test on a computer connected behind this interface to test the results of this configuration.
Step 1: Create a policy map e.g "allowed_bw_3M" to limit uplink and downlink to 3Mbps
Router#configure t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#policy-map allowed_bw_3M
Router(config-pmap)#class class-default
Router(config-pmap-c)#police cir 3072000
Note: 3 x 1024 x 1000 = 3072000 (convert to bit rate or biTs per second)
Router(config-pmap-c-police)#conform-action transmit
Router(config-pmap-c-police)#exceed-action drop
Router(config-pmap-c-police)#end
#
Step 2: Apply the policy to the interface
#
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet0/0.512
Router(config-subif)#service-policy input allowed_bw_3M
Router(config-subif)#service-policy output allowed_bw_3M
Router(config-subif)#do wr
Building configuration...
[OK]
Router(config-subif)#end
#
You can use speed test on a computer connected behind this interface to test the results of this configuration.
Wednesday, September 2, 2015
Job Advertisement for Research Assistants (40 Positions) - Resilient Africa Network
The Resilient Africa Network (RAN) - seeks to hire suitable candidates for the positions of Research Assistants who will be field based in the 4 districts of Hoima, Bududa, Amuria and Lamwo. The successful candidates will be reporting to the Field Team Supervisors.
Download the full job advert here and good luck :-)
Download the full job advert here and good luck :-)
Wednesday, August 19, 2015
Quick Link - Another Solution to gain remote access to your device at home
Note to self:
I will definitely need this very soon for my home security cameras
Remote Access with Dynamic DNS
Remote access your computer, DVR, webcam, security camera or any internet connected device easily. Dynamic DNS points an easy to remember hostname to your dynamic IP address.
I will definitely need this very soon for my home security cameras
Remote Access with Dynamic DNS
Remote access your computer, DVR, webcam, security camera or any internet connected device easily. Dynamic DNS points an easy to remember hostname to your dynamic IP address.
Quick link - Another Hosted server solution
Am saving this link on my blog so i can refer to it later when am looking for a hosted server solution.
Servers and Virtualization
Hardware you trust: your VPS servers will be located on trustedSupermicro servers with Intel Xeon CPUs, ECC RAM and Intel SSD drive arrays. Servers are never overprovisioned, meaning you will have enough power to run your applications any time.
With OpenVZ container virtualization we make sure your VPS RAM won't be spent for running Linux kernel or system drivers. All of the memory will be available for your applications and software.
Servers and Virtualization
Hardware you trust: your VPS servers will be located on trustedSupermicro servers with Intel Xeon CPUs, ECC RAM and Intel SSD drive arrays. Servers are never overprovisioned, meaning you will have enough power to run your applications any time.
With OpenVZ container virtualization we make sure your VPS RAM won't be spent for running Linux kernel or system drivers. All of the memory will be available for your applications and software.
Tuesday, August 18, 2015
My Android Phone Keeps loosing the network connection
Problem:
My android device keeps loosing network connection and every time i have to reboot it or manually search for network operator before it can reconnect again.
Solved:
Lock the phone to 2G only.
This bug is common with network operators who have both 2G and 3G networks operational.
if you phone is set to "Auto" latch onto 2G/3G, it will tend to loose the network sometimes.
You will realize that if you transfer the SIM card to a 2G only phone, the situation will be normal.
once i realized that, i decided to set my phone "network mode" to 2G only and it has been stable ever since:
My android device keeps loosing network connection and every time i have to reboot it or manually search for network operator before it can reconnect again.
Solved:
Lock the phone to 2G only.
This bug is common with network operators who have both 2G and 3G networks operational.
if you phone is set to "Auto" latch onto 2G/3G, it will tend to loose the network sometimes.
You will realize that if you transfer the SIM card to a 2G only phone, the situation will be normal.
once i realized that, i decided to set my phone "network mode" to 2G only and it has been stable ever since:
Go to Settings |
Click More ... |
Go to Mobile Networks |
Network Mode |
Choose 2G only |
Friday, August 14, 2015
Tracking routed vlan interface statistics and bandwidth shaping on Juniper switches - ex4500 series
I have just finished provisioning two different internet customers (one supposed to be 4 Mbps and the other 3 Mbps up/down) on a Juniper ex-4500-40f series switch.
The next step was to do bandwidth limiting on these customers but i have hit 2 very annoying snags with this model of juniper switch.
1. The bandwidth policer can ONLY work for ingress traffic (this would be up-link from the customer) which is usually a non issue for the ISP because Uplink is little traffic compared to down-link!
For egress traffic, am supposed to do "bandwidth-shaping" but yet again it's not supported for logical interfaces! WTF Juniper!
2. The ex-4500 does NOT support tracking RVI (Routed VLAN Interface) statistics! meaning there is no way i will be able to track the throughput for my internet customers. This is really annoying because even you SNMP tool won't be able to monitor such interfaces no matter how fancy it is!
The next step was to do bandwidth limiting on these customers but i have hit 2 very annoying snags with this model of juniper switch.
1. The bandwidth policer can ONLY work for ingress traffic (this would be up-link from the customer) which is usually a non issue for the ISP because Uplink is little traffic compared to down-link!
For egress traffic, am supposed to do "bandwidth-shaping" but yet again it's not supported for logical interfaces! WTF Juniper!
2. The ex-4500 does NOT support tracking RVI (Routed VLAN Interface) statistics! meaning there is no way i will be able to track the throughput for my internet customers. This is really annoying because even you SNMP tool won't be able to monitor such interfaces no matter how fancy it is!
Sorry if you landed on this page because of the same issue.
Funny thing is RVI stats are supported on the lower versions ex3200 and ex4200! up to now i don't know why the F*** Juniper decided to do it like this. Ideally higher switch models should inherit all the good features from it's predecessors and even get better.
Here are two screen shots from my ex4200 and the annoying ex4500!:
On the 4200 you are able to the the ingress stats whereas on the 4500 there is 0.
I really don't know if there is any work around this "show stopper" on the ex4500! please comment if you have any break through on the 4500 regarding rvi statistics or rvi egress bandwidth limiting.
will appreciate.
Thursday, August 13, 2015
Observium - Network Management and Monitoring - Another Great Free tool to Consider
Observium - Another great free network monitoring tool to consider if you are on a search for one. I already finished setting up cacti but will definitely try Observium for my next client. Can't wait to take it for a spin! |
Observium - Network Management and Monitoring |
Wednesday, August 12, 2015
Quick Check - Simple CISCO NAT Configuration
Refer to the network layout below:
Configuration:
Note:- Replace the private IPs at the p2p with the public IPs supplied by your ISP.
Replace the public dns 8.8.8.8 with your ISP DNS(s)
interface GigabitEthernet0/0
description Connects-to-ISP-router
ip address 192.168.201.2 255.255.255.252
ip nat outside
ip virtual-reassembly in
end
!
interface GigabitEthernet0/1
description Connects-to-LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
end
interface Loopback1
ip address 192.168.1.200 255.255.255.255
ip route 0.0.0.0 0.0.0.0 192.168.201.1
ip nat inside source list my-access-list interface GigabitEthernet0/0 overload
ip access-list extended my-access-list
permit ip any any
ip dhcp pool my-office-dhcp
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
lease 7
If you have any questions! Please leave a comment.
Friday, August 7, 2015
Quick Check Juniper-Junos "Disable and Enable vlan interface"
This command does the same thing as Cisco's "shutdown" and "no shutdown" interface commands:
> edit
Entering configuration mode
# set interfaces vlan.231 disable
# commit
# exit
Exiting configuration mode
>
> show interfaces vlan.231 terse
Interface Admin Link Proto Local Remote
vlan.231 down up inet 10.0.23.1/28
# delete interfaces vlan.231 disable
# commit
# exit
Exiting configuration mode
>
> show interfaces vlan.231 terse
Interface Admin Link Proto Local Remote
vlan.231 up up inet 10.0.23.1/28
>
>
> edit
Entering configuration mode
# set interfaces vlan.231 disable
# commit
# exit
Exiting configuration mode
>
> show interfaces vlan.231 terse
Interface Admin Link Proto Local Remote
vlan.231 down up inet 10.0.23.1/28
# delete interfaces vlan.231 disable
# commit
# exit
Exiting configuration mode
>
> show interfaces vlan.231 terse
Interface Admin Link Proto Local Remote
vlan.231 up up inet 10.0.23.1/28
>
>
Thursday, August 6, 2015
Wednesday, August 5, 2015
Land Cruiser 1KZ-TE Engine overhaul Budget List - Done in Uganda
I have just completed an engine overhaul job with my mechanic (Mr. Mpanga) along sir Apollo kaggwa road. Here is a list i received from my mechanic.
The whole job cost around 2.5 Million Uganda Shillings ( Approx 715 USD)
Engine Type: 1KZ-TE
1. Sleeves (Cylinder Liners) - 500,000 ugx
2. Piston Rings - 350,000 ugx
3. Piece Bearings - 90,000 ugx
4. Main Bearing - 120,000 ugx
5. Thrust Washers - 80,000 ugx
6. Cylinder Head Gasket - 130,000 ugx
7. Crankshaft Regrinding - 150,000 ugx
8. Valve Seals - 75,000 ugx
9. Engine Seals x 3 - 90,000 ugx
10. Cylinder Head Refacing - 100,000 ugx
11. Injector Pump Servicing - 70,000 ugx
12. Nasal Servicing (4 pieces) - 80,000 ugx
13. Timing Belt - 120,000 ugx
14. Fan Belts x 3 - 80,000 ugx
15. Oil Filter - 30,000 ugx
16. Engine Oil - 96,000 ugx
17. Sleeve Replacement Labor - 150,000 ugx
18. General Labor - 200,000 ugx
Total = 2,511,000 ugx (1 UGX = 0.000285720 USD)
Thanks to my Mechanic Mr. Mpanga (0752031565) for a job well done. I highly recommend him if you are thinking of doing an engine overhaul (Suzuki and Toyota).
The whole job cost around 2.5 Million Uganda Shillings ( Approx 715 USD)
Engine Type: 1KZ-TE
1. Sleeves (Cylinder Liners) - 500,000 ugx
2. Piston Rings - 350,000 ugx
3. Piece Bearings - 90,000 ugx
4. Main Bearing - 120,000 ugx
5. Thrust Washers - 80,000 ugx
6. Cylinder Head Gasket - 130,000 ugx
7. Crankshaft Regrinding - 150,000 ugx
8. Valve Seals - 75,000 ugx
9. Engine Seals x 3 - 90,000 ugx
10. Cylinder Head Refacing - 100,000 ugx
11. Injector Pump Servicing - 70,000 ugx
12. Nasal Servicing (4 pieces) - 80,000 ugx
13. Timing Belt - 120,000 ugx
14. Fan Belts x 3 - 80,000 ugx
15. Oil Filter - 30,000 ugx
16. Engine Oil - 96,000 ugx
17. Sleeve Replacement Labor - 150,000 ugx
18. General Labor - 200,000 ugx
Total = 2,511,000 ugx (1 UGX = 0.000285720 USD)
Thanks to my Mechanic Mr. Mpanga (0752031565) for a job well done. I highly recommend him if you are thinking of doing an engine overhaul (Suzuki and Toyota).
Mutual Agreement for Sale of Motor Vehicle - Republic of Uganda
Here is a quick and easy agreement you can sign between the seller and buyer (includes witnesses) of a motor vehicle in Uganda. I know most of us are lazy to draft an agreement, so here is one you can download and print to save you the hustle.
Please note that you still have to go ahead and process the motor vehicle transfer to your names to make it official with the revenue authority.
Plus, make sure to supplement this agreement with national recognized IDs (e.g. driver's permit, Passport, National ID), and a copy of the car log book.
I hope this eases your car deal.
DOWNLOAD HERE
Please note that you still have to go ahead and process the motor vehicle transfer to your names to make it official with the revenue authority.
Plus, make sure to supplement this agreement with national recognized IDs (e.g. driver's permit, Passport, National ID), and a copy of the car log book.
I hope this eases your car deal.
DOWNLOAD HERE
Tuesday, August 4, 2015
Vodafone Uganda saves you the hustle of cutting your SIM card every time you change your phone
Thanks to the new Vodafone Uganda SIM card, it comes in a "3 in 1" format already cut to fit all sizes of SIM card slots.
See the pictures below how the SIM can be assembled to fit all SIM sizes.
Big Ups Vodafone Uganda, this was a good idea.
See the pictures below how the SIM can be assembled to fit all SIM sizes.
Big Ups Vodafone Uganda, this was a good idea.
Monday, July 13, 2015
Am using whatsapp on my laptop - Thanks to BlueStacks Android Apps Player
I got issues with my "whatsapp" app on the phone, my poor Alcatel One Touch phone would freeze whenever i launch whatsapp, even after struggling and succeeding with moving the app to the SD card (How to force move apps to SD - Alcatel One Touch).
I always knew someone must have already developed an app to install whatsapp on the PC but was lazy to search for one, but my friends kept on complaining why am offline and i couldn't continue giving the lame excuse of "my phone is weak", and i was not about to get a new handset (credit cruch in my pockets at the moment :-( ).
So here is the long story in short:
Download BlueStacks Platform |
2. Install it and follow the installation steps up to the end.
3. Consider the BlueStack platform as you virtual phone on your PC
BlueStacks Android Apps Player for PCs |
4. Link it with your Google App Store/ Play Store and download whatsapp like you would on a normal android phone.
5. The rest is simple, you will need to use the "call me" option instead of the SMS option when linking whatsapp to your phone number because the SMS code will be sent to your phone not the PC.
6. Have fun "whatsapping" from your laptop, i am.
Tuesday, June 16, 2015
Just bought Yaka from Payway using my VISA card
Another one of those services that leaves you saying "Thank God for Technology".
It's 8:00 PM and am still stuck in office, and the people at home call saying Yaka is finished and they are in total darkness. My quick solution has always been to buy using Airtel or Mobile Money, but this time both my Airtel and MTN mobile money accounts were zero.
So the lazy techie hits google to see if these payway guys have actually added a web payment gateway and the good news is they actually have already integrate web payment. They are using PesaPal API as their payment gateway ...... oops sorry am going into so much details, am sure you landed on this page because you were looking for the same service. so here you go:
1. Access this page using your computer or phone: PAYWAY WEB KIOSK
2. Fill in the details; Name, Email, Billing Address, Phone Number ..... etc
3. Enter you visa/mastercard details
4. Hit pay
5. Receive the YAKA token in your email or click the "update status" page
6. Have fun
It's 8:00 PM and am still stuck in office, and the people at home call saying Yaka is finished and they are in total darkness. My quick solution has always been to buy using Airtel or Mobile Money, but this time both my Airtel and MTN mobile money accounts were zero.
So the lazy techie hits google to see if these payway guys have actually added a web payment gateway and the good news is they actually have already integrate web payment. They are using PesaPal API as their payment gateway ...... oops sorry am going into so much details, am sure you landed on this page because you were looking for the same service. so here you go:
1. Access this page using your computer or phone: PAYWAY WEB KIOSK
Payway Web kiosk |
3. Enter you visa/mastercard details
4. Hit pay
Buy yaka using VISA |
6. Have fun
Friday, March 13, 2015
Generate QRC and Barcodes online ready for printing to your products
A friend of mine asked me if i can print for him barcodes to stick to his farm products which he will be selling in supermarkets around Kampala and was willing to pay be about 50 dollars for this work.
But it turns out, i can actually do this for free, apart from the cost of printing on sticker paper and transport and thanks to this online tool.
There are so many i landed on before choosing to work with this but i don't like the other tools; some put watermarks in the barcode, some insert their website names, others insert the word Demo, but this is super clean. Thanks to "Online Barcode Generator"
But it turns out, i can actually do this for free, apart from the cost of printing on sticker paper and transport and thanks to this online tool.
There are so many i landed on before choosing to work with this but i don't like the other tools; some put watermarks in the barcode, some insert their website names, others insert the word Demo, but this is super clean. Thanks to "Online Barcode Generator"
Tuesday, February 17, 2015
iPad mini - Network carrier successfully registered but always in searching mode
Problem:
My client gave me her new iPad mini to setup her email, i opted for Airtel Uganda 3G service so i bought they normal SIM and cut it to a nano SIM because these devices use nano SIMs.
I went ahead and setup the cellular data and APN settings.
I was able to latch on to Airtel Uganda network but i observed one weird issue; on the top left corner of the display, the iPad was showing "searching Airtel" and would not lock to 3G and there were not network bars. whenever i would check under "Settings > Carrier" it was set to Automatic and registered on Airtel. And whenever you would try a manual search, it would fail!
what baffled me most is that the browsing was working thou terribly slow and sometimes the pages would not load! email failed totally.
first i suspected the SIM card and i tried using other SIM cards but the results were the same.
Solved:
I did a Software Update from the default iOS version to iOS 8.1.3
I hooked up the device to a Wi-Fi network and downloaded the latest iOS software and installed it.
Go to "General > Software Update"
I observed one important thing during the upgrade, you have to keep the device connected to Wi-Fi even after completing the download because the software is verified before it's successfully installed on the device.
Another important point was; make sure the date & time is correct otherwise the software verification might fail.
After the update was successful, the device was able to display network bars and the "searching" disappeared, and 3G was displayed next to the network carrier " ..... Airtel 3G"
if this article was useful to you, please leave a comment below. cheers.
My client gave me her new iPad mini to setup her email, i opted for Airtel Uganda 3G service so i bought they normal SIM and cut it to a nano SIM because these devices use nano SIMs.
I went ahead and setup the cellular data and APN settings.
I was able to latch on to Airtel Uganda network but i observed one weird issue; on the top left corner of the display, the iPad was showing "searching Airtel" and would not lock to 3G and there were not network bars. whenever i would check under "Settings > Carrier" it was set to Automatic and registered on Airtel. And whenever you would try a manual search, it would fail!
what baffled me most is that the browsing was working thou terribly slow and sometimes the pages would not load! email failed totally.
first i suspected the SIM card and i tried using other SIM cards but the results were the same.
iPad Mini |
I did a Software Update from the default iOS version to iOS 8.1.3
I hooked up the device to a Wi-Fi network and downloaded the latest iOS software and installed it.
Go to "General > Software Update"
I observed one important thing during the upgrade, you have to keep the device connected to Wi-Fi even after completing the download because the software is verified before it's successfully installed on the device.
Another important point was; make sure the date & time is correct otherwise the software verification might fail.
After the update was successful, the device was able to display network bars and the "searching" disappeared, and 3G was displayed next to the network carrier " ..... Airtel 3G"
if this article was useful to you, please leave a comment below. cheers.
Subscribe to:
Posts (Atom)