Search My Techie Guy

Tuesday, August 12, 2014

Error:Package:php5.4 Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)

Problem:

I was trying to update my PHP from version php-5.3.3 to version php-5.4.3 using:
 "yum install php56w.x86_64"

I kept running into this error, yet i had openssl installed and all it's libraries running fine:
# yum install php54w.x86_64

Loaded plugins: product-id, replace, security, subscription-manager
Updating certificate-based repositories.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php54w.x86_64 0:5.4.31-1.w6 will be installed
--> Processing Dependency: php54w-common(x86-64) = 5.4.31-1.w6 for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: php54w-cli(x86-64) = 5.4.31-1.w6 for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: php54w-cli = 5.4.31-1.w6 for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Running transaction check
---> Package php54w.x86_64 0:5.4.31-1.w6 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) for package: php54w-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: php54w-5.4.31-1.w6.x86_64
---> Package php54w-cli.x86_64 0:5.4.31-1.w6 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: php54w-cli-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: php54w-cli-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) for package: php54w-cli-5.4.31-1.w6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: php54w-cli-5.4.31-1.w6.x86_64
---> Package php54w-common.x86_64 0:5.4.31-1.w6 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: php54w-common-5.4.31-1.w6.x86_64
--> Finished Dependency Resolution
Error: Package: php54w-cli-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: php54w-cli-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
Error: Package: php54w-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: php54w-common-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: php54w-cli-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: php54w-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: php54w-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: php54w-cli-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: php54w-5.4.31-1.w6.x86_64 (webtatic-testing)
           Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Solution:

I upgraded my current version of openssl from openssl-1.0.0e-fips to OpenSSL 1.0.1e-fips and i was able to upgrade my PHP to 5.4

This is what i did:

1. Force remove the current openssl packages:

# rpm -e --nodeps openssl10-libs-1.0.1e-1.ius.el6.x86_64
# rpm -e --nodeps openssl-devel-1.0.0-20.el6.i686
# rpm -e --nodeps openssl-1.0.0-20.el6.i686

2. Install a new version of openssl

# rpm -ifvh /var/tmp/yum-root-M9Lg4I/openssl-1.0.1e-15.el6.x86_64.rpm 
warning: /var/tmp/yum-root-M9Lg4I/openssl-1.0.1e-15.el6.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
Preparing...                ########################################### [100%]
   1:openssl                ########################################### [100%]
# openssl
OpenSSL> version 
OpenSSL 1.0.1e-fips 11 Feb 2013
OpenSSL> 

3. Force remove all the current packages of php 5.3

# rpm -qa | grep php
php-cli-5.3.3-3.el6_1.3.x86_64
php-common-5.3.3-3.el6_1.3.x86_64
php-5.3.3-3.el6_1.3.x86_64
php-mysql-5.3.3-3.el6_1.3.x86_64
php-pdo-5.3.3-3.el6_1.3.x86_64

4. Install the new packages of php 5.4 

# rpm -qa | grep php
php54w-common-5.4.31-1.w6.x86_64
php54w-mysql-5.4.31-1.w6.x86_64
php54w-cli-5.4.31-1.w6.x86_64
php54w-pdo-5.4.31-1.w6.x86_64
php54w-5.4.31-1.w6.x86_64

5. Restarted apache and everything tested OK.
upgrading php to 5.4.31 on RHEL 6.2

Post a Comment